Mikrotik-ROS ·

ROS之VPN

必备条件
1、一个可使用的VPN(PPTP/L2TP)
2、ROS路由一个

特别注意一点,把强制DNS关掉,就是/ip dns Allow Remote Requests不要打勾!

#下载下面的附件解压得到ros-cnip-20160123.rsc
拖放到winbox的file,在New Terminal键入im ros-cnip-20160123.rsc 回车,导入国内IP列表

下面的命令也在New Terminal键入,注意不要复制注释内容,就是带#号那行

#建立外线l2tp拨号,321是用户名和密码,可以手动建,如果已做了跳过

/interface l2tp-client
add comment=USA-VPN connect-to=xxx.xxx.xxx.xxx disabled=no mrru=1600 name=l2tp-out1 password=321 user=321

#建立vpn-local网卡dhcp地址池

/ip pool
add name=vpn-dhcp ranges=192.168.40.2-192.168.40.254

#建立vpn端口dhcp服务,vpn-local是网口

/ip dhcp-server
add address-pool=vpn-dhcp disabled=no interface=vpn-local name=vpn

#设置vpn-local网口网关,vpn-local是网口

/ip address
add address=192.168.40.1/24 comment="vpn configuration" interface=vpn-local network=192.168.40.0

#设置dhcp网段,xxx.xxx.xxx.xxx请用ISP拨号得到的DNS地址

/ip dhcp-server network
add address=192.168.40.0/24 comment="vpn configuration" dns-server=8.8.8.8,8.8.4.4,xxx.xxx.xxx.xxx gateway=192.168.40.1

#标记内网网段走外线l2tp线路

/ip firewall mangle
add action=mark-routing chain=prerouting comment=USA-VPN dst-address-list=!cnip dst-address-type=!local new-routing-mark=USA-VPN src-address=192.168.40.0/24

#添加外线l2tp伪装

/ip firewall nat
add action=masquerade chain=srcnat out-interface=l2tp-out1

#添加外线l2tp路由表

/ip route
add distance=1 gateway=l2tp-out1 routing-mark=USA

参与评论